Comprobar la versión de WordPress y PHP

Cuando desarrollamos un plugin o un tema para WordPress, es posible que requieran de una versión mínima de PHP o de WordPress para que se ejecute de forma correcta, sobre todo cuando exista una alta probabilidad de que se encuentren versiones anteriores. Esto lo podemos comprobar mediante la función version_compare().

Los siguientes fragmentos de código comprueban que la versión de WordPress sea al menos la 4.5 y la de PHP la 5.6 y si no es así interrumpe la ejecución y muestra un mensaje con un enlace para volver atrás.

Comprobar la versión de WordPress:

<?php
if ( version_compare( $GLOBALS['wp_version'], '4.5', '<' ) ) {
	$msg = '<strong>Se requiere WordPress 4.5 o superior</strong> <p><a href="javascript:window.history.back();">Volver</a></p>';
	wp_die( $msg );
}
?>

Comprobar la versión PHP:

<?php
if ( version_compare( PHP_VERSION, '5.6', '<' ) ) {
	$msg = '<strong>Se requiere PHP 5.6 o superior</strong> <p><a href="javascript:window.history.back();"><p>Volver</a></p>';
	wp_die( $msg );
}
?>

Leave a Reply

Your email address will not be published. Required fields are marked *